Showing results for 
Search instead for 
Did you mean: 

water pump runs but no water

Explorer III
Explorer III

2017 Shurflo 4008.

This was all working fine about 2 weeks ago, though we don’t use it very often.

Yesterday, the pump runs continually but no water pressure. 

I can see a little water gurgling at the T valve before the pump, and I confirmed that valve is open (tried it in both open/closed to confirm which was which).

Google says these pumps can need priming/have air bubbles, or have a block. To prime, some instructions say to turn the valve to winterizing, then pour water in the hose, run the pump, voilà. I did find a hose on mine, but it is full with pink fluid. I did not put that in myself; we don’t winterize our RV, we just run heat to it if it’s going to be below freezing. Is the pink fluid antifreeze from when I bought it 7 years ago? Geez.

Anyway, since the hose has pink fluid in it, there’s no place to pour water in to prime. So that’s not going to work.

I don’t see any leaks or loose valves. Years ago with a similar problem I found a loose valve and a leak, quick twist and everything working again. No such luck this time.

What are my next steps?



Explorer III
Explorer III

I really hate this stuff.

Since there are no leaks or visible gaps, it sounds like either the pump is failing or the valve regulator is stuck. Because of where this pump is installed and the direction they oriented, you can’t access the front of the valve to remove the cover and examine the diaphragm.

And someone attached the pump to the floor with screws that are so tight you can’t remove the pump.

So how are you supposed to work on it? Replace it? 

I ended up having to remove the 8 screws on the cover of the pump blindly. In a very tight space with a very short screwdriver.

Once I got the cover off, I examined the check valve and discovered it was in fact ‘stuck’. I pushed on it hard enough to break it free. I put everything back together again, blindly. 

Put the fuse back in the breaker, turned on the water pump and voilà! water!

crazy how they would install it there in that orientation. They could have just as easily put it two inches away from the cabinet wall, oriented it 180 degrees or even 90 so you could access the front, and/or not used so much pressure that you can’t remove the pump. If the pump ever fails the screws holding it to the floor will need to be cut.

But… my water pump is working again!

The pump is getting old. The fins inside the pump can wear to the point that water gets past them. I would replace the pump.


Mark & Jan "Old age & treachery win over youth & enthusiasm"
2003 Fleetwood Jamboree 29

Explorer III
Explorer III

OK I figured out how to remove the cap and check the screen. It had a fair amount of plastic debris in it, I cleaned it out and reattached.

I drained the pink from the winterizing tube, filled with water, dropped in a bucket of winter, turned valve to witnerize, ran pump. nothing. I can feel the pulsating and a slight suction on the end of the tube but it’s not moving any water.

So I conclude that the gap, leak, or block is from the pump onward, as opposed to from the fresh water tank to the pump, because otherwise I would get suction in the winterizing position and I don’t.

Am I on the right track?

Explorer III
Explorer III

ugh, my entire reply got eaten

Thanks for the help!

- there is water in the tank, it’s full. Fair question

- outside shower is off

- friend suggested running city water through the system to remove air bubbles/pressurize, I did, it did not help

- please explain the winterize valve on the water pump. Have never used. The pink stuff is from the factory, 7 years ago. When I flipped the valve back and forth, the pink stuff did not get sucked out. That suggests to me there is not enough pressure to do so. When I removed the cap, I could pour the pink stuff out, then fill with water, then drop in bucket as suggested, then run pump?

- I don’t see anything loose, leaking, or cracked. I understand something could be loose where I can’t see it, ie in a wall or under the floor or something, which is a project I’m not sure I’m equipped to handle. If there’s a more methodical or simpler way to go about this I’m all ears.

- where is the screen or cover that I would check for debris or cracks? I tried to attach a photo but not sure it went through.

Thanks again for the help!552B057C-298A-411D-89B7-E3D91EE2A8FD.jpeg


Sounds like you are getting air in the line. I've had a few of those clear covers on the screen crack and cause a similar issue. Also, have you checked that your outside shower is turned off? And trying to omit the obvious, is there water in your FW tank? 


Jeff - 2023 FR Sunseeker 2400B MBS

Nomad II
Nomad II

Have you taken the screen off of the pump and cleaned it?  Even though you do not winterize there maybe a winterizing value and hose end that is there to pick up the antifreeze out of a jug. That would cause the issue if not in correct position or hose is cut.  You did not say if your fresh water tank is full or not. 

Itasca Meridian SE 36g
Road Master Tow Dolly

Explorer III
Explorer III

So turn the winterizing valve and run the pump, the pink stuff ain’t going to hurt anything (including you). In any event, for the most part the pink stuff should pretty much run out the end of the bypass hose, you can then you can refill it with fresh water, stick the end in a bucket of water, should be good to go then.