cancel
Showing results for 
Search instead for 
Did you mean: 

My Gmail turned to Russian!

mr__ed
Explorer
Explorer
I have 2 gmail accounts. Today,one of them showed up in Russian. A long time ago, I had a similar problem, but that time it appeared to be Chinese. So I went ahead and changed passwords on both accounts as a precaution. I don't remember what I did for the Chinese situation, but perhaps the problem just went away. Have any of you had a similar thing happen, and is it anything to be concerned about?
Mr. Ed (fulltiming since 1987)
Life is fragile. Handle with prayer.

2007 Hitchhiker II LS Model 29.5 LKTG (sold)
2007 Dodge Ram 3500/6.7 CTD/QC/4X4/SB/SRW/6-speed man/Big Horn edition (sold)
9 REPLIES 9

mr__ed
Explorer
Explorer
TurnThePage wrote:
I don't think Windows version will have much to do with it. Probably a browser issue.


You’re right. All is back to normal now. It was nothing to be concerned about. :C
Mr. Ed (fulltiming since 1987)
Life is fragile. Handle with prayer.

2007 Hitchhiker II LS Model 29.5 LKTG (sold)
2007 Dodge Ram 3500/6.7 CTD/QC/4X4/SB/SRW/6-speed man/Big Horn edition (sold)

TurnThePage
Explorer
Explorer
I don't think Windows version will have much to do with it. Probably a browser issue.
2015 Ram 1500
2022 Grand Design Imagine XLS 22RBE

mr__ed
Explorer
Explorer
Everything seems ok now, at least on my iPad. I’ll be checking my Windows Pc later..
Mr. Ed (fulltiming since 1987)
Life is fragile. Handle with prayer.

2007 Hitchhiker II LS Model 29.5 LKTG (sold)
2007 Dodge Ram 3500/6.7 CTD/QC/4X4/SB/SRW/6-speed man/Big Horn edition (sold)

monkey44
Nomad II
Nomad II
Mr Ed ... I'm using Windows 10 Pro as well. As stated above, I get language change on certin pages. It's been happening as long as I've been using Wdw10, so not new. I've never been able to fix it but there's never been an issue beyond it.

But, Russian hacking, very doubtful, more like a glitch in Wdw 10...
Monkey44
Cape Cod Ma & Central Fla
Chevy 2500HD 4x4 DC-SB
2008 Lance 845
Back-country camping fanatic

mr__ed
Explorer
Explorer
wildtoad wrote:
What system are you using? Windows, Chrome, Mac, iOS(Apple)? I’ve had iOS incorrectly identify where I was before. Can’t remember how I fixed it.


I Should have mentioned that. I'm using Windows 10 Pro. I was thinking maybe it's due to Russian hacking, as mentioned on the news, but somehow I doubt that. Hopefully the issue will just disappear. I feel better about changing the passwords. These sites were overdue for it anyway. :C
Mr. Ed (fulltiming since 1987)
Life is fragile. Handle with prayer.

2007 Hitchhiker II LS Model 29.5 LKTG (sold)
2007 Dodge Ram 3500/6.7 CTD/QC/4X4/SB/SRW/6-speed man/Big Horn edition (sold)

wa8yxm
Explorer III
Explorer III
Changing passwords is a good idea when this happens.
Let me check something Yup if you get into settings the language is easy to farkel (At least on the version I use) same as I'm sure you reset it.

I've had that happen on several web services.. Usually i hit "French" by accident.
Home was where I park it. but alas the.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times

wildtoad
Explorer II
Explorer II
What system are you using? Windows, Chrome, Mac, iOS(Apple)? I’ve had iOS incorrectly identify where I was before. Can’t remember how I fixed it.
Tom Wilds
Blythewood, SC
2016 Newmar Baystar Sport 3004
2015 Jeep Wrangler 2dr HT

monkey44
Nomad II
Nomad II
Not sure why, but one of my Amazon product pages only reads in French, and another one reads in Spanish. I change both to English, and next time I open either one, it reverts to Spanish or French.

I repeat buy often, so I just ignore it and click the button. The product delivers as if I ordered it properly. I have no clue why it happens. Some glitches fool everyone, and never resolve.

If you continue to revert it to English in settings, it may remains English once gmail cycles into its new orbit periodically.
Monkey44
Cape Cod Ma & Central Fla
Chevy 2500HD 4x4 DC-SB
2008 Lance 845
Back-country camping fanatic

2oldman
Explorer II
Explorer II
Can't say I have, but I would suspect it's erroneously detecting your location. No matter what I do I cannot get google maps to detect my location, at all.
"If I'm wearing long pants, I'm too far north" - 2oldman