cancel
Showing results for 
Search instead for 
Did you mean: 

A/C amperage draw?

freewayrandy49
Explorer II
Explorer II

How many amps should a 15K a/c pull at startup? I have a new Cougar 5er and am going nuts getting a generator that will run my a/c on boondock trips. I had soft start installed when I bought it. So far I've tried a Generac 3300, a Champion 4650, now a Predator 5000 and all have overloaded at a/c startup! A friend came over and did a amp draw test and the rig pulled 42 amps at startup! Could I have a bad soft start? Was it wired wrong?  Totally frustrated!!!

20 REPLIES 20

SofaKing
Explorer
Explorer

Assuming it's running on 110v, then a 5000 watt generator is 45 amps (watts/voltage=amps), if it's 120v then it's 41.6amps.  Either way that should be surge current and will decrease once running.  However, if you have other things running at the same time that are already pulling current, then the total load during that surge can be very high.  

StirCrazy
Navigator
Navigator

a 15K will run on a 30amp breaker no issues, the start up should be way less than 30amps considering the running amprage is around 14 to 16 depending on the brand.  I would find out about the soft start on it and if it is hooked in right or if it is even in good shape.  is it a digital soft start of a capacitor setup and does it still use the factory capacitors.  if so there might be a bad capacitor as that will cause an unusualy high starting current and is easy to check and replace.

2014 F350 6.7 Platinum
2016 Cougar 330RBK
1991 Slumberqueen WS100

Grit_dog
Nomad III
Nomad III

Does it pop a breaker if you run it off a 15-20A household circuit?

From what you said, it will, but idk, something don’t sound right. The odds you got 3 junk 2nd rate generators is quite low, but the odds of a 2nd rate generator performing like it should are a bit higher. 

2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29 - Sold.
Couple of Arctic Fox TCs - Sold


@Grit_dog wrote:

Does it pop a breaker if you run it off a 15-20A household circuit?

From what you said, it will, but idk, something don’t sound right. The odds you got 3 junk 2nd rate generators is quite low, but the odds of a 2nd rate generator performing like it should are a bit higher. 


The generator isn’t the problem (1st rate or 2nd rate) if the A/C was pulling 42 amps at startup as the OP stated.

Oh ok. Sure the soft start might not be working and if not, a 15k will pull a min 30-35a briefly and easily could be more (on startup). 
if it only pulled 16-18amps then soft starts wouldn’t have been invented. lol. 
Just being helpful, buddy. 

2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29 - Sold.
Couple of Arctic Fox TCs - Sold

And to clarify for the OP, he could have either or both issues mentioned, bad soft start or capacitor, but my suggestion of trying it on a residential circuit assuming one is available, is a free easy test to help find the issue. 
It should run no problem off a 20a resi circuit with adequate size ext cord and may, off of a 15a with a soft start. 
if it does for either or both, it’s just evidence that it may be the soft start issue or generator issue, or…who knows maybe op is using an insufficient extension cord. 
There are a few different factors that the OP wasn’t specific aboot that could affect the outcome. 

2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29 - Sold.
Couple of Arctic Fox TCs - Sold

We found that the soft start is wired wrong. Taking it back to dealer since it is under warranty.

ewarnerusa
Nomad
Nomad

Yeah doesn't sound right.  Those size generators seem like they should run the AC even without soft start.  With soft start installed when you got it, I assume you can't confirm if the AC worked before soft start?  soft start is supposed to go through several cycles of compressor startup when on true shore power so that it can be "trained" on the AC's startup profile, do you know if that happened?  Although I'm not sure how that could describe this, I remember it is a thing.

Aspen Trail 2710BH | 470 watts of solar | 2x 6V GC batteries | 100% LED lighting | 1500W PSW inverter | MicroAir on air con | Yamaha 2400 gen

way2roll
Navigator
Navigator

Why does the User/OP show "not applicable"? Their name/user name is gone. 


Jeff - 2023 FR Sunseeker 2400B MBS

because he was never a member, he browsed the site as a visitor and posted a question.  

2014 F350 6.7 Platinum
2016 Cougar 330RBK
1991 Slumberqueen WS100

Latner
Nomad
Nomad

If it is a bad soft start, I would install one of these:  Microair 

one of my mistakes was getting a Microair

 

Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp-hours of Telcom jars, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.


@pianotuna wrote:

one of my mistakes was getting a Microair

 


why do you say that PT?

2014 F350 6.7 Platinum
2016 Cougar 330RBK
1991 Slumberqueen WS100

Because it didn't "play well" with either the load support on the magnum 3000 inverter charger nor my auto former. In retrospect it was, for me, a waste of money. And yes, I did ask the company if it would be a good plan.

Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp-hours of Telcom jars, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.