cancel
Showing results for 
Search instead for 
Did you mean: 

Could not get slide to come in Freedom Express 192 RBS

jjjandrbaker
Explorer
Explorer

Last week I pushed the button to bring in the slide and nothing happened- no sound, no vibration, no movement- nothing! I spent the day checking fuses, breakers, wires, and the battery. Nothing solved the problem. Finally, a neighbor saw a video that showed how to get the slide in manually. He worked for about 30 minutes and brought it in so I could finally head home. But, the problem still remains. I have read the manual for the slide, searched the internet for things I didn't already try, and posted on some FB groups. The only thing I have heard that sounds feasible is to check the fuse for the slide. Problem is that I can't find it. I'm hoping someone on here who has a 192rbs can tell me where to look. It isn't in the manual. All it says is that the slide out fuse may be blown.

Jim Baker
San Antonio, TX
travel blog and photos
1 REPLY 1

bid_time
Nomad
Nomad

It would help to know what kind (brand, type, and model) of slide you’re talking about there are probably 20 or 30 different slides. Otherwise we’re shooting in the dark and may be providing totally irrelevant information.