cancel
Showing results for 
Search instead for 
Did you mean: 

Victron battery monitor help

dieseltruckdriv
Explorer II
Explorer II
I got it installed, but it won't read any amps. At all. I have double checked that it is wired correctly, and there are no connections to the negative terminal other than the shunt. I get voltage readings but no amps whether charging or discharging. It reads zero.

Is there anywhere to buy a new circuit board for the shunt? I can find nothing on their website.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L
39 REPLIES 39

Cydog15
Explorer
Explorer
dieseltruckdriver wrote:
hedge wrote:
For me that was one of the reasons I went with the Victron. My monitor is mounted in a back cupboard where it is not seen. I monitor everything with the app via bluetooth. The app is also nice for setup.
I would have done that, but I needed to cover a hole that originally held a solar charge controller, plus I don't use my phone much when I am in the 5er.

Do you mean it's easier or easier to do it sitting down. I have no problem pushing a few buttons but it's not the easiest thing to program. I like the Trimetric so far.

dieseltruckdriv
Explorer II
Explorer II
hedge wrote:
For me that was one of the reasons I went with the Victron. My monitor is mounted in a back cupboard where it is not seen. I monitor everything with the app via bluetooth. The app is also nice for setup.
I would have done that, but I needed to cover a hole that originally held a solar charge controller, plus I don't use my phone much when I am in the 5er.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L

dieseltruckdriv
Explorer II
Explorer II
Cydog15 wrote:
dieseltruckdriver wrote:
Cydog15 wrote:

Precisely why I would have bought the Trimetric 2030RV. You get to talk to people but hope you get this resolved.

That was my first choice, but the 5er is less than 6 months old, and DW said no way to that since it had to be mounted in the living room area. I had to agree with her that they are ugly, and my sense of style when dressing up is a clean t shirt.

The old once are, the new units are not. Smaller with better neutral colors.
The newer ones were the ones I showed her.

Yes they still are.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L

hedge
Explorer
Explorer
For me that was one of the reasons I went with the Victron. My monitor is mounted in a back cupboard where it is not seen. I monitor everything with the app via bluetooth. The app is also nice for setup.
2017 F350 Platinum DRW
2013 Adventurer 89RB

CharlesinGA
Explorer
Explorer
dieseltruckdriver wrote:
I solved the problem this evening. I brought home my Fluke Networks cable toner, as it also will do a "wire map". Basically what it does is make sure the connections on a Cat X cable are correct. The Victron uses a 3 pair cable (6 wires) to communicate from the shunt to the display. Sure enough, the cable had a bad end on it. It looked good, but when I cut it off and put a new end on the cable, I went from 1 good pair to 3 good pairs. Problem solved.

I am kind of frustrated with myself for not checking this earlier. I am also slightly frustrated with Victrons customer service. They would only tell me to contact my dealer. I bought it off Amazon, and the selling dealer would not answer my emails. I then tried a couple other dealers, and told them I thought I had screwed it up somehow and was willing to pay for the part, but they had to check to see if they could get the small board that mounts on the shunt. I have still never heard from them either.

I am guessing they would have been more responsive if I had purchased from them, but I offered to pay for everything. At least it is fixed now.

I must not be too frustrated, I bought a Victron pure sine wave inverter. 😉
I tested that immediately to make sure it worked. It works well.


Here at my house with one router, one cable modem, two printers on ethernet, a network disk drive and the desktop, I have had two or three ethernet cables suddenly go bad. Spend quite a bit of time troubleshooting only to discover putting in a new cable solves the issue. I no longer trust such cables.

This fellow loves Victron stuff and has done a number of videos on his installs. They even hired him to do some video work for them after seeing his Youtube videos.

Journey with Jono

Charles
'03 Ram 2500 CTD, 5.9HO six speed, PacBrake Exh Brake, std cab, long bed, Leer top and 2008 Bigfoot 25B21RB.. previously (both gone) 2008 Thor/Dutchman Freedom Spirit 180 & 2007 Winnebago View 23H Motorhome.

Cydog15
Explorer
Explorer
dieseltruckdriver wrote:
Cydog15 wrote:

Precisely why I would have bought the Trimetric 2030RV. You get to talk to people but hope you get this resolved.

That was my first choice, but the 5er is less than 6 months old, and DW said no way to that since it had to be mounted in the living room area. I had to agree with her that they are ugly, and my sense of style when dressing up is a clean t shirt.

The old once are, the new units are not. Smaller with better neutral colors.

Cydog15
Explorer
Explorer
dieseltruckdriver wrote:


I am kind of frustrated with myself for not checking this earlier. I am also slightly frustrated with Victrons customer service. They would only tell me to contact my dealer. I bought it off Amazon, and the selling dealer would not answer my emails. I then tried a couple other dealers, and told them I thought I had screwed it up somehow and was willing to pay for the part, but they had to check to see if they could get the small board that mounts on the shunt. I have still never heard from them either.

I am guessing they would have been more responsive if I had purchased from them, but I offered to pay for everything. At least it is fixed now.

I must not be too frustrated, I bought a Victron pure sine wave inverter. 😉
I tested that immediately to make sure it worked. It works well.

I've been done with Amazon for over a year. Especially electrical stuff. BTW there is a new battery monitor out for those that want simplicity with a 350 amp shunt. Expion 360. Not sure who all is going to sell it but I know they won't let Amazon, at least that's what they said when my SIL inquired. They have a website but no links to dealers yet.

CA_Traveler
Explorer III
Explorer III
Ugly electonics :@



OK Hide it in a cabinet. :C
2009 Holiday Rambler 42' Scepter with ISL 400 Cummins
750 Watts Solar Morningstar MPPT 60 Controller
2014 Grand Cherokee Overland

Bob

dieseltruckdriv
Explorer II
Explorer II
Cydog15 wrote:

Precisely why I would have bought the Trimetric 2030RV. You get to talk to people but hope you get this resolved.

That was my first choice, but the 5er is less than 6 months old, and DW said no way to that since it had to be mounted in the living room area. I had to agree with her that they are ugly, and my sense of style when dressing up is a clean t shirt.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L

Cydog15
Explorer
Explorer
dieseltruckdriver wrote:
Well, I can't find anywhere to buy one either, and it was an Amazon purchase. I tried contacting the seller and have gotten no response yet. The return window closed on Friday, I wish I had watched that closer. Victron told me to contact the dealer, so I am stuck in a loop. 🙂

I thought maybe someone might know of a place to get one.

Thanks to everyone that has tried to help, it is appreciated. I will try to remember and post a follow up when I get this resolved.

Precisely why I would have bought the Trimetric 2030RV. You get to talk to people but hope you get this resolved.

dieseltruckdriv
Explorer II
Explorer II
I solved the problem this evening. I brought home my Fluke Networks cable toner, as it also will do a "wire map". Basically what it does is make sure the connections on a Cat X cable are correct. The Victron uses a 3 pair cable (6 wires) to communicate from the shunt to the display. Sure enough, the cable had a bad end on it. It looked good, but when I cut it off and put a new end on the cable, I went from 1 good pair to 3 good pairs. Problem solved.

I am kind of frustrated with myself for not checking this earlier. I am also slightly frustrated with Victrons customer service. They would only tell me to contact my dealer. I bought it off Amazon, and the selling dealer would not answer my emails. I then tried a couple other dealers, and told them I thought I had screwed it up somehow and was willing to pay for the part, but they had to check to see if they could get the small board that mounts on the shunt. I have still never heard from them either.

I am guessing they would have been more responsive if I had purchased from them, but I offered to pay for everything. At least it is fixed now.

I must not be too frustrated, I bought a Victron pure sine wave inverter. 😉
I tested that immediately to make sure it worked. It works well.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L

Donnoh
Explorer
Explorer
dieseltruckdriver wrote:
2oldman wrote:
I'll bite. What were you looking at when going through the menus?
I could really post a smart alec response about food, but I won't!
I was actually checking the shunt settings, and battery AH capacity, and something else I thought might have a wrong setting, but right now I can't think of what it was. It didn't matter, they were all ok.


I'll be curious as to what you find the problem to be. My 712 has a 4 conductor phone cable that connects the head unit to the shunt. I'm wondering if they use two conductors for power and the other two conductors as a communication bus for the current and temperature feedback or they overlay the current/temp communication on the power wires, which doesn't sound likely.

dieseltruckdriv
Explorer II
Explorer II
2oldman wrote:
I'll bite. What were you looking at when going through the menus?
I could really post a smart alec response about food, but I won't!
I was actually checking the shunt settings, and battery AH capacity, and something else I thought might have a wrong setting, but right now I can't think of what it was. It didn't matter, they were all ok.
2000 F-250 7.3 Powerstroke
2018 Arctic Fox 27-5L

2oldman
Explorer
Explorer
I'll bite. What were you looking at when going through the menus?
"If I'm wearing long pants, I'm too far north" - 2oldman