cancel
Showing results for 
Search instead for 
Did you mean: 

New Suburban Water Heater Won't Light

EZinColo
Explorer
Explorer
Howdy,
New member from Colorado. We have a 1998 Gulf Stream Conquest (23 ft Class C)

I installed a new Suburban water heater (WH) - gas only. After connecting it up I hit the WH switch in the coach and heard the burner light. The tank was empty so I turned it off immediately. After filling the tank I hit the reset button on the face of the WH, toggled the WH switch and the "pilot out" light went on. I cycled the switch a few times (per the manual) and this light went off, but got no ignition.

I got down and checked the three wires you have to connect to the WH for installation (red, blue and yellow). I used crimp connectors - which I'm not crazy about, although the coach is full of them - but thought maybe one was loose. So I gave each a couple tugs. I also read about cheap controller boards failing (from a burned component) so I opened the controller board enclosure, checked the board, the multi-wire connector and the high voltage wire to the ignitor. Everything was good so I screwed it back to the wall.
I guess I'd left the WH switch ON because about 10 seconds later the burner lit. Woohoo!

Assuming the crimp connectors were indeed the problem, I turned off the WH switch and decided to go outside and solder those connections (can't reach wires from the inside). Before I did this I wanted to hear the burner light again, so I turned the WH switch back on - no joy.

I went ahead and soldered the connections anyway and tried the WH switch (after hitting the reset button again) - nothing. But I didn't get the "pilot out" light either.

For the record, I’ve got 12.8V across my coach battery. I’ve also checked the DC fuses several times and nothing is blown.

At this point I'm out of ideas. Does anyone have a suggestion?
What am I missing?


Thanks a lot.

Eric
1 REPLY 1

dougrainer
Explorer
Explorer
1. NO such thing as a Pilot light, on your model. Just a standard flame.
2. You need to post Model number of the new W/H
3. Also, the W/H has a tri start board. It will try 3 times to light with pauses of about 15 seconds between attempts. Does it do that?
4. Turn the gas OFF, attempt to light and let it go for 5 minutes. DOES THE RED LIGHT COME ON? It should. If not, you may have miswired the new heater. Did the NEW W/H come with the same color 3 wires as the old one?
5. It could be as simple as a bad Ignition module. Doug