cancel
Showing results for 
Search instead for 
Did you mean: 

A/C issue resolved

wa8yxm
Explorer III
Explorer III
One of my original Carriers was replaced oh 8 or 9 years ago with an Advent Air (I'd not recommend 'em but they quit making 'em)

Well it's been one fun machine. First the fan went BOOM I kid you now replaced with a coleman fan so not is sucks instead of blows. I might add cleaning it with the original fan was no joy either (Way easier now)

Then the new trick is when the compressor REstarts (First start is ok) Click goes the breaker.

Well I had a hard start kit so I added it. Improvement (now only once every day or two) Till I got back here in a full sun site then Clik-o-matic yesterday (But take heart) I had the replacement start cap (The dual cap that starts both blower and compressor)

Got it put in this AM before the Sun turned to BROIL and now I am cool and comfortable. More cool and more comfortable than in a long time under today's weather conditions.

And Since I kept the Hard Start kit and put it in with the new cap the start is "Softened" to the point where I do not hear the compressor kick in... I can tell it is running if I pay attention but I do not hear it start over the air flow noise.

Very happy.> Very very happy .
Home was where I park it. but alas the.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times
1 REPLY 1

pianotuna
Nomad II
Nomad II
Great to hear you are cool as a cucumber!
Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp-hours of Telcom jars, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.