cancel
Showing results for 
Search instead for 
Did you mean: 

IRV 66 - won't power up

Ranger431
Explorer
Explorer
Has anyone had an issue with an IRV 66 audio system / DVD player not powering up? Pulled the TT out of storage today and the radio won't power up. The screen wont do anything and no lights at all other than a dull red light on the power button. I have confirmed it has power and the fuses in both the main panel and the inline fuse in the wire heading into the back of the unit are both in tact and have power.

Any ideas?
2020 Jayco Eagle 355 MBQS

2011 Ford F-350
7 REPLIES 7

jmcgirt
Explorer
Explorer

Does anyone know if there is a replacement brand that will fit into the cutout for the dead iRV66?

 

wa8yxm
Explorer III
Explorer III
drsteve wrote:
If it has power and won't function, it's probably dead...


Ditto on that.
The unit has two (or 3) power leads
One is "MEMORY" Power. hooked to battery full time

One is "Accessory" only powered when ignition is in ACC position or a switch somewhere is in AUX position (optional swtich)

But if the power switch is lit, it has power

(3rd one is Dash Light by the way on the power leads).

I the switch lights up with key on and headlights off. Good chance it has power (only the one lead ACC, is needed to operate) And is dead.
Home was where I park it. but alas the.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times

Ranger431
Explorer
Explorer
After trying for hours to navigate the horrible voicemail / switchboard system at Patrick Industry (the manufacturer of IRV) I lucked out and spoke with someone today that said he'd put me in touch with the Tech Manager to see if there is anything I could do - doesn't sound promising.

Wish the warranty was a little more substantial - over a 1 year period it probably has less than a weeks worth of continuous use.

If it is dead, I somehow don't see myself paying the $400 or so bucks to replace it. Are there any other options out there anyone can recommend?
2020 Jayco Eagle 355 MBQS

2011 Ford F-350

Ranger431
Explorer
Explorer
Yes, hooked to shore power (50 amp). All fuses are good and everything else is working. No info in the manual other than confirming power, which I know is good all the way to the inline fuse. I realize the prognosis isn't good, but was hoping there might be some magical "factory reset" that wasn't in the manual.
2020 Jayco Eagle 355 MBQS

2011 Ford F-350

drsteve
Explorer
Explorer
Are you plugged in to shore power? Are your other 12V items working, lights, water pump, furnace, etc?
2006 Silverado 1500HD Crew Cab 2WD 6.0L 3.73 8600 GVWR
2018 Coachmen Catalina Legacy Edition 223RBS
1991 Palomino Filly PUP

navegator
Explorer
Explorer
Is it hooked to the battery, how much charge does the battery have?

Plug the TT to ahousehold outlet so that the battery charger gets charged and see if that is the cause?

You do mention a very dim red light, that means low voltage, not enough to turn the sistem on.

navegator

drsteve
Explorer
Explorer
If it has power and won't function, it's probably dead...
2006 Silverado 1500HD Crew Cab 2WD 6.0L 3.73 8600 GVWR
2018 Coachmen Catalina Legacy Edition 223RBS
1991 Palomino Filly PUP