cancel
Showing results for 
Search instead for 
Did you mean: 

Cruise control

wjschill
Explorer
Explorer
Our cruise control stopped working on our F53 frame MH. It has the ford v-10 engine.

Any ideas what I can check?

All advice appreciated.

Skip
KillingTime
10 REPLIES 10

Dutch_12078
Explorer
Explorer
Glad to see you got it sorted out with minimal expense, Skip!
Dutch
2001 GBM Landau 34' Class A
F53 chassis, Triton V10, TST TPMS
Bigfoot Automatic Leveling System
2011 Toyota RAV4 4WD/Remco pump
ReadyBrute Elite tow bar/Blue Ox baseplate

wjschill
Explorer
Explorer
OP here.

Dutch was right on the mark.

I YOU-TUBED that CC switch on the master cylinder, and saw where this has been a problem on many Ford trucks. I found it on Amazon for about $38.00.

Mine was actually on a line below the MC, and very easy to change out.

Everything works as it should, now.

Thanks to all for your responses.

Skip
KillingTime

rjstractor
Nomad
Nomad
wjschill wrote:
OP here.

We are part timers, and last outing was in January, and it worked fine.

However, the windshield washer pump failed, which I replaced, and now works.

Don't know if there's anything in that area of the motor that I might have disturbed.

Also, this is a 2014 Tiffin Allegro gasser.

Thanks guys.

Skip


I'm not familiar with where exactly the WW pump is in relation to the master cylinder or other parts are located, but logically it makes sense that the two could be related if the CC failed immediately after you did the work. As was mentioned earlier, there are no vacuum lines or any type of mechanical linkage that operate your cruise control. Ford has used a drive by wire system for several years, so there is no mechanical connection between your foot and the engine. A possible failure point is a faulty speed sensor, but when that happened to me in a different model Ford motorhome, I also got an ABS warning light.
2017 VW Golf Alltrack
2000 Ford F250 7.3

wjschill
Explorer
Explorer
OP here.

We are part timers, and last outing was in January, and it worked fine.

However, the windshield washer pump failed, which I replaced, and now works.

Don't know if there's anything in that area of the motor that I might have disturbed.

Also, this is a 2014 Tiffin Allegro gasser.

Thanks guys.

Skip
KillingTime

Dutch_12078
Explorer
Explorer
The switch on the master cylinder is a not uncommon CC failure point.
Dutch
2001 GBM Landau 34' Class A
F53 chassis, Triton V10, TST TPMS
Bigfoot Automatic Leveling System
2011 Toyota RAV4 4WD/Remco pump
ReadyBrute Elite tow bar/Blue Ox baseplate

PastorCharlie
Explorer
Explorer
Clock Spring under steering wheel.

RLS7201
Explorer
Explorer
wa8yxm wrote:
There are a lot of posibilities.
First the CC uses vacuum so if you have a vacuum leak in the right place. NO CC.
I had a bent pin on a connection.
Blown fuse (it uses 12 volt as well) other bad connection

Bad brake light switch. Have someone stand behind the RV and see if the brake lights are on full time.

Also blown brake light fuse/burned out bulbs. Have partner make sure they come on when you push the pedal

NOTE that last is my #1 suspect.

On edit. a bad GROUND on the brake lights will do it too. But not consistantly(IE when headlights on no CC.. lights off it works).


You are WRONG AGAIN........V10 F53s do NOT use vacuum.

Richard
95 Bounder 32H F53 460
2013 CRV Toad
2 Segways in Toad
First brake job
1941 Hudson

wa8yxm
Explorer III
Explorer III
There are a lot of posibilities.
First the CC uses vacuum so if you have a vacuum leak in the right place. NO CC.
I had a bent pin on a connection.
Blown fuse (it uses 12 volt as well) other bad connection

Bad brake light switch. Have someone stand behind the RV and see if the brake lights are on full time.

Also blown brake light fuse/burned out bulbs. Have partner make sure they come on when you push the pedal

NOTE that last is my #1 suspect.

On edit. a bad GROUND on the brake lights will do it too. But not consistantly(IE when headlights on no CC.. lights off it works).
Home was where I park it. but alas the.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times

wildtoad
Explorer II
Explorer II
My 2016 F53 cruise stopped too. Has the 6 spd transmission.
Tom Wilds
Blythewood, SC
2016 Newmar Baystar Sport 3004
2015 Jeep Wrangler 2dr HT

garym114
Explorer II
Explorer II
What year ?
2000 Sea Breeze F53 V10 - CR-V Toad
Some RV batteries live a long and useful life, some are murdered.
Get a Digital Multimeter and Learn How to Use It