Showing results for 
Search instead for 
Did you mean: 

Atwood Furnace issues

Any help appreciated
Atwood furnace afsd20121 Winnebego micro 22'
At first would work a couple of cycles then no ignition. Reset and that is an issue as furnace has no outside access and well, lot of work to pull out

1. cleaned sail switch of dust bunny
2.furnace fired up
3. then fan only

As of last night new dinosaur board but bought from Amazon. Fan only no ignition
board locked out and fan would not restart although I reset
Today still no fan. Long story short.....
1. jumped out tstat and limit switch(which had continuity but to make sure) Installed new sail switch.
2. power at reset and connection on board for power. Nothing coming from fan conn on board.

all connections look good, seems to be in board. I reinstalled old board, same result.
I'm thinking I got a bad board from Amazon.


Gas valve is not easily accessible but I will definately check that out later. Great information.

Page 6 lower left corner says there is a switch to inhibit propane valve from operating. Shown on circuit drawing page 7 left side.
Have you seen such an item in yours?

USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker

The usual suspects are in order of likely failure on an Atwood/Dometic are 1. Sail switch 2. Board 3. Limit switch 4. Electrode/Flame sensor.  If it's firing at all it's not the sail switch, the sail switch is either open or closed, there's no in between. The limit switch on an RV furnace is really a high limit switch, if it's stuck open the furnace won't ignite, otherwise it's purpose is to cut ignition if the chamber temp exceeds 190°F. The board is the furnace brain, so if it's bad nothing will function correctly. The electrode fires the furnace and the flame sensor signals the board that flame is present. 

The sail sw., limit sw. and electrode are the cheapest fixes and I'd replace those first, if still no success replace the board. At the worst you'll have spare parts